ChibiStudio Linux debug protocol

Discussions and support about ChibiStudio, the free development environment for ARM.
joaquin
Posts: 36
Joined: Sat Jan 22, 2011 8:44 pm
Been thanked: 2 times

ChibiStudio Linux debug protocol

Postby joaquin » Tue Jul 30, 2019 8:33 pm

I wanted to give a try to the ChibiStudio for Linux; in the installation instructions it's said that "There is a known issue: Debug launch configurations in ChibiOS projects must be manually updated, select "OpenOCD TCP/IP" as protocol then everything should work. Launch configurations will be eventually updated in ChibiOS but that will happen when also ChibiStudio for Windows will be updated."

I've tried to identify where to change that protocol, but I'm unable to find it.
Anybody would be so kind as to give me a hint on where to change it?

Thanks a lot!
Joaquin

User avatar
Giovanni
Site Admin
Posts: 13528
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 861 times
Been thanked: 743 times
Contact:

Re: ChibiStudio Linux debug protocol

Postby Giovanni » Tue Jul 30, 2019 8:47 pm

Hi,

From the debug drop down meno (the bug icon in the toolbar):
- Select "Debug Configurations...".
- Open "GDB Hardware Debugging" and select the launch configuration inside (it is the one of the currently opened project).
- Select the "Debugger" tab.
- In the "JTAG Device" drop down change from "Generic TCP/IP" to "OpenOCD via socket".
- Apply, Close.

Giovanni

joaquin
Posts: 36
Joined: Sat Jan 22, 2011 8:44 pm
Been thanked: 2 times

Re: ChibiStudio Linux debug protocol

Postby joaquin » Tue Jul 30, 2019 9:48 pm

I reached that point, but I was looking for the OpenOCD TCP/IP...
Thanks a lot, I'll try it


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 3 guests