ChibiStudio Discovery F4 debugger not in pull down problem

Discussions and support about ChibiStudio, the free development environment for ARM.
kb1gtt
Posts: 37
Joined: Sat Jul 09, 2016 11:29 am
Has thanked: 11 times
Been thanked: 2 times

ChibiStudio Discovery F4 debugger not in pull down problem

Postby kb1gtt » Fri Oct 23, 2020 9:43 pm

I've been following the video's at PLAY Embedded tutorials and I'm currently on this one.
https://www.youtube.com/watch?v=BsQm4db ... ex=4&t=29s

At 1:29, I'm expecting to see a pull down option. However as you can see in the below snap screen shot, the option is not there. How do I get this option? Do I need to do something with the debug configurations?

ChibiStudio_Debug_issue.png


This is Win10 64bit with ChibiStudio_Windows_2020-04.7z and I have launched Eclipse via Chibi Studio GCC 9.0 shortcut. This is a Discovery F407 board.

User avatar
Giovanni
Site Admin
Posts: 13527
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 861 times
Been thanked: 743 times
Contact:

Re: ChibiStudio Discovery F4 debugger not in pull down problem

Postby Giovanni » Sat Oct 24, 2020 8:19 am

Hi,

The guide is not updated, in newer ChibiOS the debug files are no more included in the projects (those .launch files under /debug, there were hundreds of them), you need to generate them:

1) Compile the project.
2) Select the generated .elf file under ./build in the Projects Explorer.
3) From the tools menu (where you launch OpenOCD) there is a option to generate the debug files.
4) Files are generated under ./debug and should appear in the debug menu.

In order to use those you need:
1) Launch OpenOCD.
2) Select the .elf file you want to debug (you could have more than one in some demos).
3) Use the debug configuration in the debug menu.

The guide is valid except you need to generate the .launch files first.

Giovanni


Return to “ChibiStudio”

Who is online

Users browsing this forum: No registered users and 1 guest