lpc4357 lwip - solved

ChibiOS public support forum for topics related to the NXP LPC family of Cortex-M micro-controllers.
Posts: 21
Joined: Sat Nov 22, 2014 8:23 pm

lpc4357 lwip - solved

Postby gvandenbosch » Thu Apr 23, 2015 1:54 pm

UPDATE Error was between keyboard and chair, I found out I configured the pin for GPIO already and double initialized the TX pins.


I am a bit stuck with the LWIP on the LPC4357.
Took the demo with LWIP of 4330 as example, and changed the PHY ID to my own chip.
Enabled emac in halconf and enabled clocks in mcuconf.

Everything seems to run fine, when I send an ARP request I receive it in the code and can walk through it how it tries to handle it.
At a certain moment is calls "mac_lld_write_transmit_descriptor".

My guess is that this writes back to the ethernet port...
But I see no reply on my ARP request coming back, neither any other packets (checked with wireshark).

I am a bit clueless how to properly debug this, does anyone have a pointer for me?


Return to “LPC Support”

Who is online

Users browsing this forum: No registered users and 2 guests