Is anyone using Chibi on the nRF51?

ChibiOS public support forum for topics related to the Nordic nRF51 family of micro-controllers.

Moderator: utzig

szego
Posts: 20
Joined: Wed Sep 02, 2015 7:51 pm

Is anyone using Chibi on the nRF51?

Postby szego » Fri Oct 30, 2015 12:46 am

Just wondered - has anyone got this working? Using the SoftDevice?

flabbergast
Posts: 71
Joined: Sat Aug 22, 2015 1:22 pm

Re: Is anyone using Chibi on the nRF51?

Postby flabbergast » Fri Oct 30, 2015 9:14 am

No idea about the capabilities of the nRF51 port, but there is one in the contrib tree (I think by utzig, barthess and doceme).

User avatar
Giovanni
Site Admin
Posts: 13585
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 876 times
Been thanked: 750 times
Contact:

Re: Is anyone using Chibi on the nRF51?

Postby Giovanni » Fri Oct 30, 2015 9:26 am

It is a new port, Fabio Utzig is handling it, just wait for him to comment.

Giovanni

bubune
Posts: 3
Joined: Mon Dec 21, 2015 11:38 pm

Re: Is anyone using Chibi on the nRF51?

Postby bubune » Mon Dec 21, 2015 11:53 pm

Hi,

I've ported Chibios about 2 years ago on the nrf51. At this time I've used last revison of Chibios (2.6.5). Chibios is running perfectly with different drivers like uart, spi, i2c, timers.... I've started to integrate the softdevice one year ago but it's not working correctly. I don't know why, but IRQ are not enabled when I call specific softdevice functions but are enabled when normal functions :-(

see my thread on the nordic semi forum:
https://devzone.nordicsemi.com/question ... interrupt/

I've put on GITHUB my port, all details of the issue are in "main.c" and the readme file:
https://github.com/bubune/Chibios_NRF51_SD

If someone can helping me, will be nice.

Bruno

bubune
Posts: 3
Joined: Mon Dec 21, 2015 11:38 pm

Re: Is anyone using Chibi on the nRF51?

Postby bubune » Thu Jan 14, 2016 10:44 pm

Hi,

just to let you know the issue is fixed and the port look stable. I run the demo for 30min with a ANT+ HRM belt without any issue :-)
Let me know if you find a problem.

I hope it will be usefull for someone.

It's easy to port and use the nordicsemi bluetooth stack S130 and other...

Regards,
Bruno

Raul
Posts: 43
Joined: Thu Aug 13, 2015 5:15 pm
Has thanked: 3 times
Been thanked: 1 time

Re: Is anyone using Chibi on the nRF51?

Postby Raul » Wed Jan 20, 2016 9:45 pm

Hi Bruno,

Good job and very interesting, do you thing it will also support BLE instead of ANT+ and should also support other soft devices like SD110?

Will try to follow your steps for those cases, it would be quite neat to get ChibiOS running on it.

Regards,

Raul

bubune
Posts: 3
Joined: Mon Dec 21, 2015 11:38 pm

Re: Is anyone using Chibi on the nRF51?

Postby bubune » Thu Jan 21, 2016 9:55 am

Hi Raul,

I'm currently working on a improved demo by using SD310 to use both stack (ANT and BLE). Insteand to send data over UART, in the new demo, the UART BLE profile will be use. From that, it should be easy to use other SD from Nordic.

I will post news here when it will be done. However, I can not tell you when it will be done. I'm very busy at home, and I've urgent task to be done before.

Bruno


Return to “nRF51 Support”

Who is online

Users browsing this forum: No registered users and 1 guest