DMA driver issue with STM32L011 Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
Posts: 197
Joined: Tue Sep 03, 2013 8:16 pm
Has thanked: 3 times
Been thanked: 16 times

DMA driver issue with STM32L011  Topic is solved

Postby dflogeras » Sat May 01, 2021 1:26 pm


Running ChibiOS-20.3.3, I'm playing with a board based around an STM32L011. I started with the template project in demos/STM32/NIL-STM32L011K4-NUCLEO32.

If I enable I2C1, the following compile error happens:

Code: Select all

In file included from ../os/hal/ports/STM32/STM32L0xx/stm32_isr.c:55:
../os/hal/ports/STM32/LLD/DMAv1/ In function ‘Vector6C’:
../os/hal/ports/STM32/LLD/DMAv1/ error: ‘STM32_DMA1_STREAM6’ undeclared (first use in this function); did you mean ‘STM32_DMA1_STREAM1’?
   71 |   dmaServeInterrupt(STM32_DMA1_STREAM6);
      |                     ^~~~~~~~~~~~~~~~~~
      |                     STM32_DMA1_STREAM1
../os/hal/ports/STM32/LLD/DMAv1/ note: each undeclared identifier is reported only once for each function it appears in
../os/hal/ports/STM32/LLD/DMAv1/ error: ‘STM32_DMA1_STREAM7’ undeclared (first use in this function); did you mean ‘STM32_DMA1_STREAM1’?
   74 |   dmaServeInterrupt(STM32_DMA1_STREAM7);
      |                     ^~~~~~~~~~~~~~~~~~
      |                     STM32_DMA1_STREAM1

The device datasheet sates this one has only DMA 5 channels, so I'd guess there's just a missing #ifdef somewhere? If I comment out the two offending calls in os/hal/ports/STM32/LLD/DMAv1/ I can move forward, but that's obviously not the correct fix.

User avatar
Site Admin
Posts: 13807
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 934 times
Been thanked: 796 times

Re: DMA driver issue with STM32L011

Postby Giovanni » Fri Aug 20, 2021 10:30 am


Fixed as bug #1181. Not tested on HW.


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 4 guests