SPI HAL v2 fails to compile without SPI_USE_SYNCHRONIZATION Topic is solved

Report here problems in any of ChibiOS components. This forum is NOT for support.
nikiwaibel
Posts: 15
Joined: Sat Mar 17, 2018 2:51 pm
Has thanked: 4 times
Been thanked: 10 times

SPI HAL v2 fails to compile without SPI_USE_SYNCHRONIZATION  Topic is solved

Postby nikiwaibel » Tue Dec 14, 2021 9:32 pm

a new version of the SPI HAL was added in -r15007.

if the new driver is used without enabling SPI_USE_SYNCHRONIZATION, compilation fails due to wrong number of arguments in the define __spi_wakeup_isr() (which does nothing else then hiding/erasing the code). the following diff patches the relevant code line:

Code: Select all

$ svn diff
Index: os/hal/include/hal_spi_v2.h
===================================================================
--- os/hal/include/hal_spi_v2.h   (revision 15244)
+++ os/hal/include/hal_spi_v2.h   (working copy)
@@ -382,7 +382,7 @@
   osalSysUnlockFromISR();                                                   \
 }
 #else /* !SPI_USE_SYNCHRONIZATION */
-#define __spi_wakeup_isr(spip)
+#define __spi_wakeup_isr(spip, msg)
 #endif /* !SPI_USE_SYNCHRONIZATION */

 /**

nikiwaibel
Posts: 15
Joined: Sat Mar 17, 2018 2:51 pm
Has thanked: 4 times
Been thanked: 10 times

Re: SPI HAL v2 fails to compile without SPI_USE_SYNCHRONIZATION

Postby nikiwaibel » Wed Jan 12, 2022 2:28 pm

gentle reminder: /trunk in -r15345 has not yet been fixed, as far as i can see …

User avatar
Giovanni
Site Admin
Posts: 14025
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 989 times
Been thanked: 832 times
Contact:

Re: SPI HAL v2 fails to compile without SPI_USE_SYNCHRONIZATION

Postby Giovanni » Wed Jan 12, 2022 2:32 pm

Hi,

Don't worry, fixes come in batches, it will happen on the next "pass".

Giovanni

User avatar
Giovanni
Site Admin
Posts: 14025
Joined: Wed May 27, 2009 8:48 am
Location: Salerno, Italy
Has thanked: 989 times
Been thanked: 832 times
Contact:

Re: SPI HAL v2 fails to compile without SPI_USE_SYNCHRONIZATION

Postby Giovanni » Sat Jan 22, 2022 7:54 am

Hi,

Fixed as bug #1213.

Giovanni


Return to “Bug Reports”

Who is online

Users browsing this forum: No registered users and 2 guests